[VS 2010 Beta 1] Una precisazione sulle versioni del Framework .NET e la versione 4.0

Dato che è una domanda che ricorre abbastanza frequentemente su alcuni newsgroup e anche in alcune e-mail che ho ricevuto, è doverosa una precisazione in merito alle varie versioni del Framework .NET.

Quando installate la versione 3.5 del Framework .NET, in realtà installate un’estensione della versione 3.0 che, a sua volta, è un’estensione della versione 2.0. Di conseguenza, se sviluppate con la versione 3.5, dovete avere necessariamente anche le versioni 2.0 e 3.0 (e naturalmente le avete anche installate o le installate insieme alla 3.5).

La versione 4.0 del Framework .NET non è un’estensione: è un Framework .NET completo che non richiede l’installazione o la presenza delle versioni precedenti.

Ciò non toglie che sulla stessa macchina possono (e devono poter) coesistere diversi programmi che fanno uso di versioni del Framework .NET. Inutile, quindi, chiedersi come disinstallare le versioni precedenti del Framework .NET: a meno che non abbiate veramente dei grossi problemi di spazio su disco (e non potete comprare un nuovo hard disk più capiente), potete anche lasciare tutte le versioni “storiche” lì dove sono!

Pubblicato il 26 maggio 2009 su VS 2010. Aggiungi ai preferiti il collegamento . Lascia un commento.

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger cliccano Mi Piace per questo: