[WP7] Problema dopo installazione del Service Pack 1 di VS 2010

Dopo aver installato con successo il Service Pack 1 di Visual Studio 2010 (per gli amici "SP1"), ho avuto un problema con i progetti per Windows Phone 7.

Infatti, tentando di eseguire un’applicazione WP7 (anche "vuota", cioè un’applicazione appena creata dal relativo template), invece di far partire l’emulatore, Visual Studio 2010 tentava di collegarsi al dispositivo fisico.

Ecco quindi un primo messaggio di errore:

image

Se confermiamo premendo Sì, otteniamo un altro errore:

image

… e ancora:

image

Con tanta insistenza non si può fare che una cosa: avviare Zune! Se lo fate, appare il seguente errore:

image

… e ovviamente:

image

Ok, allora colleghiamo lo SmartPhone con Windows Phone 7 e riproviamo!

Niente da fare, ancora un errore:

image

… e questa volta non c’è niente da fare: se non avete sottoscritto l’accesso la MarketPlace, non potete sbloccare il dispositivo.

L’unico modo per risolvere il problema e, almeno, testare le proprie applicazioni per WP7 è utilizzare l’emulatore interno a Visual Studio 2010. Per ripristinare questa modalità che prima dell’installazione del SP1 era quella predefinita (e l’unica), dovete utilizzare la casella a discesa che trovate nella parte superiore dell’ambiente di sviluppo:

image

Selezionando la voce Windows Phone 7 Emulator potrete evitare i problemi che ho evidenziato, perché potrete utilizzare l’emulatore interno.

Pubblicato il 13 marzo 2011 su Novità. Aggiungi ai preferiti il collegamento . 3 commenti.

  1. Ciao Mario… ma allora io non potrò mettere SP1???? Io testo SOLO su device! C’è modo di debuggare normalmente su device? Non è che SP1 vuole già NoDo?
    Grazie e ciao

    Mi piace

    • SP1 ti permette di scegliere se vuoi testare sull’emulatore di VS 2010 oppure direttamente sul device.
      Però per fare il deploy sul device devi aver avviato Zune, devi aver collegato il dispositivo (e fin qui è ovvio) e devi avere il codice di sblocco (probabilmente fornito dal MarketPlace? Non essendo iscritto non posso verificare…).

      Mi piace

  2. Ah! ok, così si. Ci suole il dispositivo sbloccato da un account Marketplace! :o)
    Grazie!

    Mi piace

Lascia un commento

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger cliccano Mi Piace per questo: